Finally Fixed!!!Speedo not working again!

Suspension; Gearbox, Clutch and Driveshafts; Brakes; Steering; Throttle and clutch cable issues
Forum rules
Hints, tips and guides for repair and modification - the FAQ section on the main website is worth checking first for information relating to common faults and technical help. Useful posts and guides will be added to the FAQ http://www.sciroccoregister.co.uk/scirocco-faq
mark1gls
Posts: 3954
Joined: Thu Apr 02, 2009 9:28 pm
fill in the right answer: 10
Location: Somerset

Re: Speedo not working again!

Post by mark1gls »

No worries always happy to help so ask away…

Just checked underneath my car and snap… my outer CV boot is split so I’ll be changing mine ASAP.

You do need a big socket for the hub nut and a long bar a tight, I use an old torque wrench with a 2m length of scaffolding pole so make sure you loosen the hub nut before lifting the car as you will need to pull the handbrake on and in 1st gear.

The CV joint should be the type which you knock off with a rubber mallet (don’t use a metal hammer as you can damage the CV joint case) hold the end straight and hit it… then it should slide off.

Make sure you get the kit with a new hub nut as washers etc as it’s a use once item.


Mk1 78 Scirocco GLS 1.6 FR, weekend toy.
Mk1 88 Golf GTi cabriolet 1.8 DX. Daily drive.
Membership No. 323
mark1gls
Posts: 3954
Joined: Thu Apr 02, 2009 9:28 pm
fill in the right answer: 10
Location: Somerset

Re: Speedo not working again!

Post by mark1gls »

I’m trying a Febi one as the GKN one I fitted last time (from Euro car parts) is now split after only 3 years old and done 18,000 miles….

I’ve just order this one.

https://www.ebay.co.uk/itm/175032956847 ... R4qG9eGYYg


Mk1 78 Scirocco GLS 1.6 FR, weekend toy.
Mk1 88 Golf GTi cabriolet 1.8 DX. Daily drive.
Membership No. 323
smudger28
Posts: 124
Joined: Sat Jan 14, 2023 7:09 pm
fill in the right answer: 15
Location: Falmouth, Cornwall

Re: Speedo not working again!

Post by smudger28 »

Update on the gearbox refurb.

The gearbox is out and on the bench and this is the findings:

Crankshaft oil seal has gone
Bush/seal for the input shaft
Driveshaft oil seal
Sealing cap at the end of the gearbox - All seals easily replaced

Flywheel badly damaged - Coming from the USA

Both transmission arms are knackered - He thinks these have to been sent away to be refurbed. I thought I could get these off Ebay new?

As for the Speedo, it was the plastic spline which had snapped and luckily retrievable from the gearbox.

So all in all not too bad.


1986 MK2 Scirocco - GTX - 120k
mark1gls
Posts: 3954
Joined: Thu Apr 02, 2009 9:28 pm
fill in the right answer: 10
Location: Somerset

Re: Speedo not working again!

Post by mark1gls »

If your removing the green cap on the end it’s worth fitting a new thrust bearing and a good clean out as it can get gummed up in there.

https://www.ebay.co.uk/itm/221185983385 ... R474v9OjYg

It sounds like the usual seals need replacing and easy job to do especially with the gearbox on the bench.

Not 100% sure what you mean by transmission arms? Is it the drive shafts?


Mk1 78 Scirocco GLS 1.6 FR, weekend toy.
Mk1 88 Golf GTi cabriolet 1.8 DX. Daily drive.
Membership No. 323
smudger28
Posts: 124
Joined: Sat Jan 14, 2023 7:09 pm
fill in the right answer: 15
Location: Falmouth, Cornwall

Re: Speedo not working again!

Post by smudger28 »

Morning Mark

Haha yes the drive shafts . Apologies for my lack of mechanical knowledge... I've looked online and there are loads on there that say they will fit, yet the mechanic reckons we need to send them away?


1986 MK2 Scirocco - GTX - 120k
mark1gls
Posts: 3954
Joined: Thu Apr 02, 2009 9:28 pm
fill in the right answer: 10
Location: Somerset

Re: Speedo not working again!

Post by mark1gls »

There is 2 sizes of drive shaft CV’s but I guess yours are 100mm flange and early cars had 90mm flanges on the gearbox, check you get the right size, either measure the end of the CV joint or gearbox flange.

Lots out there as the Mk1 Golf cabriolet used the same running gear.
Don’t know which ones are best regards build quality etc as both my car have the original drive shafts and CV joints.
Might be worth a shout out on the Facebook page to see what makes others have used as there is some poor quality items out there…

Don’t know the cost of getting the original ones refurbished compared to buying new?


Mk1 78 Scirocco GLS 1.6 FR, weekend toy.
Mk1 88 Golf GTi cabriolet 1.8 DX. Daily drive.
Membership No. 323
smudger28
Posts: 124
Joined: Sat Jan 14, 2023 7:09 pm
fill in the right answer: 15
Location: Falmouth, Cornwall

Re: Speedo not working again!

Post by smudger28 »

Hi Mark

The garage actually phoned yesterday to say they could get new ones for £118 and a refurb would cost £130. I think the boy is opting for new as the costs are beginning to mount up :-o


1986 MK2 Scirocco - GTX - 120k
mark1gls
Posts: 3954
Joined: Thu Apr 02, 2009 9:28 pm
fill in the right answer: 10
Location: Somerset

Re: Speedo not working again!

Post by mark1gls »

Yes sounds a good idea to get new drive shafts.
Keep hold of the old ones so you can check them and possibly sell them on if they look ok as spares or repair to recoup some money.


Mk1 78 Scirocco GLS 1.6 FR, weekend toy.
Mk1 88 Golf GTi cabriolet 1.8 DX. Daily drive.
Membership No. 323
smudger28
Posts: 124
Joined: Sat Jan 14, 2023 7:09 pm
fill in the right answer: 15
Location: Falmouth, Cornwall

Re: Speedo not working again!

Post by smudger28 »

Gearbox Update

The gearbox has been refurbished and waiting to go back in. We've asked the mechanic if he'd change the gearbox linkage too as there is a lot of play in the gearstick. Hopefully be sometime this week that we get the car back. Just needs an MOT now :-D

The problem with the Speedo was the plastic drive spline had snapped in two..


1986 MK2 Scirocco - GTX - 120k
smudger28
Posts: 124
Joined: Sat Jan 14, 2023 7:09 pm
fill in the right answer: 15
Location: Falmouth, Cornwall

Re: Speedo not working again!

Post by smudger28 »

Gearbox Update

So they phoned today to say the gearbox is all back in and working with no leaks but the Speedo still is not working grrrr. They’ve put a drill on the cable side and took it up to 60mph so the cable and gauge are not the issue.

What else could it be? I’ve ordered 2 more plastic spines but from Heritage parts this time and not EBay.

Are the splines hard to line up?

Thanks


1986 MK2 Scirocco - GTX - 120k
smudger28
Posts: 124
Joined: Sat Jan 14, 2023 7:09 pm
fill in the right answer: 15
Location: Falmouth, Cornwall

Re: Finally Fixed!!!Speedo not working again!

Post by smudger28 »

So we got the Rocco back from the clutch and gearbox specialists last night to the tidy sum of £1425. To be fair we had loads of work done over the 2 months it's been with them.

We did eventually get to the bottom of the speedo not working. The brand new cable we got from VW Classics was slightly bent at the gear drive end, which must've pulled the plastic spines away from the gearbox side of things therefore no contact being made. I asked the mechanic if he could bend it back slightly to centre and it worked! So going to leave it as it at the moment instead of forking out another £40 for a cable.

Thanks again for all the helpful info. MOT tomorrow and the beast is back on the road, fingers crossed!


1986 MK2 Scirocco - GTX - 120k